Missing texture after add new actors

Anything libgdx related goes here!

Missing texture after add new actors

Postby Alcadur » Thu May 16, 2019 8:52 am

I want to add two types of characters multiple times but when I add a new actor to stage texture in "old" actors stops render.

I can add multiple KnightActor (without RatActor) or multiple RatActor (without KnightActor). When I try to add multiple KnightActor and RatActor on one stage only textures from the newest actors are rendered (one RatActor and one KnightActor)

Repo url: https://github.com/Alcadur/game-tmp
GameDev question: https://gamedev.stackexchange.com/questions/171955/missing-texture-after-add-new-actors
Alcadur
 
Posts: 2
Joined: Thu May 16, 2019 8:48 am

Re: Missing texture after add new actors

Postby evilentity » Thu May 16, 2019 11:59 am

You wont have much luck with question like that, not many people will be willing to look at large project to find a bug.

You are clearing the screen in BaseActor. Probably not helping.
Looking for a freelancer? PM me!
Check out libgdx discord server!
evilentity
 
Posts: 4849
Joined: Wed Aug 24, 2011 11:37 am

Re: Missing texture after add new actors

Postby Alcadur » Thu May 16, 2019 12:12 pm

evilentity wrote:Probably not helping

You must start playing a lottery game :P , You hit the point.
I did not suppose, that will make some strange behavior

P.S.: If You want, paste the answer on GameDev, I will mark it as answer
Alcadur
 
Posts: 2
Joined: Thu May 16, 2019 8:48 am


Return to Libgdx

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 1 guest