Robovm

Anything libgdx related goes here!

Robovm

Postby exception » Fri Feb 07, 2020 4:56 am

I recently upgraded my Mac to Catalina so I'm just trying to get everything up to date, including upgrading Intellij from 2017.x to 2019.3. And I thought I may as well update libgdx from 1.9.9 to 1.9.10.

My experience is that it is easier to create a new project and just copy everything over. I created an empty project using the setup tool but couldn't get RoboVM to work.

I have been using MOE with 1.9.9 but it seems RoboVM is the default now.

[ERROR] Couldn't start application
java.lang.NullPointerException

I read that this is a common error and clearing the component tag in ios.iml would fix it. But somehow I keep getting this error after clearing the iml file. I have been trying different versions of the RoboVM Grade plugin but no luck. I have Xcode 11 installed.

Anything else I can try?
exception
 
Posts: 24
Joined: Tue Jun 14, 2016 1:19 pm

Re: Robovm

Postby wolfieee » Mon Feb 10, 2020 7:12 pm

Try switching to the snapshot version (2.3.9-SNAPSHOT) in your main gradle file. The current version isn't working at all any more. (maven http: vs https: changes)
wolfieee
 
Posts: 232
Joined: Sun May 20, 2012 1:59 am

Re: Robovm

Postby exception » Tue Feb 11, 2020 2:18 am

Thanks.

You mean the RoboVM plugin? I think I did change that.. Here's what I have now. Pretty much what was generated from the setup file:

Code: Select all
buildscript {
   

    repositories {
        mavenLocal()
        mavenCentral()
        maven { url "https://plugins.gradle.org/m2/" }
        maven { url "https://oss.sonatype.org/content/repositories/snapshots/" }
        jcenter()
        google()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.5.0'
        classpath 'com.mobidevelop.robovm:robovm-gradle-plugin:2.3.9-SNAPSHOT'
       

    }
}

allprojects {

    version = '1.0'
    ext {
        appName = "LIBGDX1910"
        gdxVersion = '1.9.10'
        roboVMVersion = '2.3.9'
        box2DLightsVersion = '1.4'
        ashleyVersion = '1.7.0'
        aiVersion = '1.8.0'
    }

    repositories {
        mavenLocal()
        mavenCentral()
        jcenter()
        google()
        maven { url "https://oss.sonatype.org/content/repositories/snapshots/" }
        maven { url "https://oss.sonatype.org/content/repositories/releases/" }
    }

exception
 
Posts: 24
Joined: Tue Jun 14, 2016 1:19 pm

Re: Robovm

Postby obigu » Tue Feb 11, 2020 6:27 pm

Try adding

Code: Select all
<option name="useQualifiedModuleNames" value="true" />


to .idea/gradle.xml file.

See https://dkimitsa.github.io/2020/01/09/i ... ource-set/
obigu
 
Posts: 147
Joined: Fri Aug 02, 2013 4:47 pm

Re: Robovm

Postby exception » Wed Feb 12, 2020 8:18 am

Thanks.... but it is already there in the gradle.xml file.....
exception
 
Posts: 24
Joined: Tue Jun 14, 2016 1:19 pm


Return to Libgdx

Who is online

Users browsing this forum: Google [Bot] and 1 guest